
PageDraw Help
PageDraw is a powerful drawing program. Using PageDraw you can create illustrations composed of 
graphical shapes such as rectangles, ellipses, polygons, bezier curves, and text. PageDraw has 
powerful tools for drawing, editing and transforming graphical objects. After you have drawn a few 
objects, you can select an object or a group of objects, and transform them. Objects can be edited even 
after transformation. To edit an object, select the object and drag any of the handles that become visible.

The following two sections describe the tools available on the tool bar on the left. To select a tool, click 
on the button representing the tool on the tool bar. Operations started using any tool can be canceled at 
any time by selecting another tool from the tool bar. Note that the shift key can be used to modify the 
operation of most tools.

How to draw
Line
Horizontal line
Vertical line
Rectangle
Square
Ellipse
Circle
Arc
Curve
Polygon
Text

After you have drawn an object, you can transform the object in a number of ways. You can transform an
object independently or you can select a group of objects to be transformed together. PageDraw treats 
text and graphics uniformly during transformation.

How to transform objects
Move
Scale
Rotate
Skew
Reflect

How to...
Include your drawing in Microsoft Word or other word processors
Change orientation to portrait or landscape mode
How to zoom in and zoom out
How to change color of lines, fills or text
Change line thickness, color or dash style
Change fill color or pattern
Draw arrow heads at line ends
Pick color, pattern and other attributes from one object and apply it to another
Group objects
Align and space objects

Miscellaneous
Interoperability with other applications
Send me your comments, bug reports, and request for new features



PageDraw is FREE software
NO WARRANTY

This Help file was written for PageDraw Version 2.0



How to draw a line

Select the line tool from the tool bar. Click the left mouse button where you want the line to start. Without
releasing the button, drag the mouse to the point where you want the line to end.

To constrain the line to a vertical or horizontal line, hold down the shift key while dragging the mouse.



How to draw a polygon

Select the polygon tool from the tool bar. Click the left mouse button where you want the first vertex of 
the polygon. Without releasing the button, drag the mouse to the point where you want the second 
vertex, then release the button. Click the left mouse button where you want the next vertex and release 
the button. Click and release the left mouse button where you want the next vertex, and the next, and so
on. When you come to the last vertex, double click the left mouse button.

To draw a closed polygon, double click on the first vertex, as the last vertex.



How to draw a rectangle

Select the rectangle tool from the tool bar. Click the left mouse button where you want the first corner of 
the rectangle. Without releasing the button, drag the mouse to the point where you want the opposite 
corner of the rectangle.

To constrain the rectangle to a square, hold down the shift key while dragging the mouse.



How to draw an ellipse

Select the ellipse tool from the tool bar. Click the left mouse button where you want the center of the 
ellipse. Without releasing the button, drag the mouse till the ellipse has the desired size and shape.

To constrain the ellipse to a circle, hold down the shift key while dragging the mouse.



How to draw an arc

Select the arc tool from the tool bar. Click the left mouse button where you want the center of the arc. 
Click the left mouse button where you want the arcs starting angle. Without releasing the button, drag 
the mouse anticlockwise to the ending angle, while also moving away from the center till the arc has the 
desired radius.



How to draw a pie slice

Select the pie tool from the tool bar. Click the left mouse button where you want the center of the pie. 
Click the left mouse button where you want the pie slices starting angle. Without releasing the button, 
drag the mouse anticlockwise to the ending angle, while also moving away from the center till the pie 
slice has the desired radius.



How to draw a curve

Select the curve tool from the tool bar. Click the left mouse button where you want the first vertex of the 
curve. Without releasing the button, drag the mouse to the point where you want the second vertex, then
release the button. Click the left mouse button where you want the next vertex and release the button. 
Click and release the left mouse button where you want the next vertex, and the next, and so on. When 
you come to the last vertex, double click the left mouse button.

To draw a closed curve, double click on the first vertex, as the last vertex.

To create a corner vertex as opposed to a smooth vertex, hold down the shift key while creating the 
vertex.



Transforming means moving, scaling, rotating, skewing or reflecting objects.



How to draw text

Select the text tool from the tool bar. Click the left mouse button where you want the text to start. Without
releasing the button, drag the mouse to draw a rectangular text-frame, then release the button. Now 
start typing. When you reach the right edge of the text-frame the cursor will move to the next line 
automatically. The text-frame will automatically increase in height to accommodate the new line. If you 
resize the text-frame, text will reflow automatically. To resize the text-frame, select the selection tool from
the tool bar. Then select the text-frame and drag any of its handles. You only need to set the width of the
text-frame. PageDraw determines the height of the text-frame automatically.

To edit existing text, select the text tool from the tool bar and click the left mouse button on the baseline 
of the text you would like to edit. Use left and right arrow keys to position cursor. Use backspace key to 
delete characters.

To use a different font, select Font from the Text menu. The font dialog only lists PostScript fonts. Fonts 
are listed by their PostScript names.

To change line spacing select Leading from the Text menu. Leading is the distance from the base of one
line to the base of the next line. 

You can also left-align, center, right-align or justify text by selecting the appropriate alignment command 
from the Text menu. 

The text tool will only work if you have installed Adobe Type Manager (ATM) software. PageDraw 
requires ATM Version 2.01 or later. Only ATM fonts, i.e., PostScript Type 1 fonts are supported. 
TrueType and other font formats are not supported in this version of PageDraw. 

What is Adobe Type Manager?
Adobe Type Manager software enables other application software such as word processors and 
graphics programs to display high quality scaleable PostScript Type 1 fonts on the screen, as well as 
print them on laser and dot-matrix printers. ATM is more powerful than the TrueType functionality built in 
to MS-Windows because ATM is capable of applying arbitrary transforms (such as skewing) to fonts.

Where to get Adobe Type Manager?
If you have installed a word processor such as Word Perfect or Ami Pro on your machine, you may 
already have ATM. Visit your local software store, or contact Adobe Systems Inc. at (800)833-6687 to 
obtain the latest version of Adobe Type Manager.



How to move objects

First, select the objects you would like to move. Click the left mouse button on the edge of (not inside) 
any one of the selected objects. Without releasing the button, drag the mouse until the objects have 
been moved to the desired position; then release the button.

To undo move, select Undo from the Edit menu before unselecting the objects.



How to scale objects

First, select the objects you would like to scale. Select the scale tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to scale the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the mouse button, drag the mouse 
until the objects have been scaled to the desired size.

To scale objects uniformly in horizontal and vertical directions, hold down the shift key while dragging the
mouse.

To undo scale, select Undo from the Edit menu before unselecting the objects.



How to rotate objects

First, select the objects you would like to rotate. Select the rotate tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to rotate the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been rotated through the desired angle.

To rotate the objects in steps of 15 degrees, hold down the shift key while dragging the mouse.

To undo rotate, select Undo from the Edit menu before unselecting the objects.



How to skew objects

First, select the objects you would like to skew. Select the skew tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to skew the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been skewed to the desired shape.

To constrain the skewing to either horizontal or vertical direction, hold down the shift key while dragging 
the mouse.

To undo skew, select Undo from the Edit menu before unselecting the objects.



How to reflect objects

First, select the objects you would like to reflect. Select the reflect tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to reflect the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been reflected about the desired line.

To undo reflect, select Undo from the Edit menu before unselecting the objects.



How to select objects

Select the selection tool from the tool bar. Click the left mouse button in an empty area near the objects 
you would like to select. Without releasing the button, drag the mouse until the selection marquee 
encloses the objects you would like to select. An object need not be enclosed entirely within the 
selection marquee in order to get selected. If a small portion of the object falls within the selection 
marquee, it will be included in the selection.

You can also toggle the selection status of an object, i.e., remove an object from the selection if it is 
already included in the selection, or add it to the selection if it is not already included. To toggle the 
selection status of an object, hold down the shift key while following the same steps as when you select 
an object.

To unselect all objects, click in an empty area on the page.



How to import your drawing into a word processor

Drawings created using PageDraw can be included in documents created using LaTeX, Microsoft Word, 
Ami Pro, or other word processors. To import your drawing into a word processor, save your drawing in 
EPS format. Use the EPS inclusion capability of your word processor to include the drawing in a 
document. Since EPS files created by this version of PageDraw do not contain a preview, the drawing 
will only appear as a rectangle in the word processor. However, when the document is printed on a 
PostScript printer, the drawing will appear correctly in its place.

To save your drawing in EPS format, choose Export from the File menu. Then change the Save file as 
type to EPS.

Technical information for advanced users: About the EPS file format

EPS stands for Encapsulated PostScript. PostScript is a powerful graphics language understood by 
printers which are equipped with a PostScript Interpreter. An Encapsulated PostScript file contains 
PostScript code designed to be included as a part of another page, rather than being sent to a 
PostScript printer directly. All EPS files contain PostScript code. However, PostScript code is in general 
only understood by printers equipped with a PostScript interpreter. Word processors do not understand 
PostScript code, and therefore cannot directly display PostScript files on the screen. To solve this 
problem, EPS files may contain a preview bitmap in addition to the PostScript code. When you insert an 
EPS file into a word processor, your word processor ignores the PostScript code that it cannot 
understand, and instead depends on the preview bitmap to display the drawing on the screen. But when 
the word processor prints the document, it sends the PostScript code to the printer instead of the 
bitmap. This assumes your printer is equipped with a PostScript interpreter. If it is not, your word 
processor sends the preview bitmap to the printer, resulting in relatively poor quality.

Now, not all EPS files contain preview bitmaps. When you insert an EPS file which does not contain a 
preview bitmap into a word processor, the word processor will not be able to display the drawing on the 
screen. Your word processor may instead display some details about the EPS file such as its name and 
the date it was created. Even though the EPS file does not contain a preview bitmap, it still contains all 
the PostScript code necessary to print the picture. So when you print the document, the word processor 
sends the PostScript code to the printer and the drawing will appear in the output. Again, this assumes 
that your printer is a PostScript printer. If it is not, the word processor will not be able to print the graphic.

EPS files created by this version of PageDraw do not contain a preview bitmap. So your word processor 
will not be able to display the drawing on the screen. But it will be able to print the drawing, assuming 
your printer can understand PostScript.

Trouble shooting

If your word processor is unable to print the EPS drawing you created using PageDraw, check the 
following:
1. Does your printer support PostScript? If it does not, consider purchasing one that does. If you plan to 
print plenty of graphics you need a printer that supports PostScript. PCL printers are fine if you only plan 
to print text, but if you want good quality graphics output you must have a PostScript printer. PageDraw 
produces higher quality output on printers that support PostScript. 600 DPI PostScript laser printers are 
available today for less than $1000.
2. Does your printer driver know that your printer supports PostScript? If your printer supports both PCL 
and PostScript you may be using a PCL printer driver. Install the PostScript printer driver that came with 
your printer.





Drawing programs and Painting programs

Drawing programs are vector-based. They let you modify objects such as circles, lines, rectangles etc. 
Drawing programs do not let you modify individual pixels. PageDraw is a drawing program.

Painting programs are bitmap-based. They let you modify individual pixels. However, painting programs 
do not let you modify objects such as rectangles, circles etc. An example of a painting program is 
Paintbrush.

Drawing programs print at the highest resolution supported by your printer. Output from painting 
programs look grainy.



How to change orientation to portrait or landscape mode

You can change the orientation of the page at any time to portrait or landscape mode and continue 
drawing. Select Orientation from View menu and choose the orientation you want to change to. Since 
orientation is only a view mode, you can switch from one orientation to another and back as many times 
as you want.



How to change fill style

To change the fill style of objects, first select    the objects which you want to change. Then choose the 
pattern or color you want from the Fill menu. The fill style you choose will remain in effect for the objects 
you draw later, until you change the fill style again.



How to change line style

To change the line style of objects, first select    the objects which you want to change. Then choose the 
dash style, line width or color you want from Line menu. Note that dashed lines can only be 1 point wide.
The line style you choose will remain in effect for the objects you draw later, until you change the line 
style again. 



How to change color of lines, fills or text 

Select the objects you want to change. Then choose Color from the Line menu to change line color, or 
Color from the Fill menu to change fill color. To change color of text objects choose Color from the Fill 
menu.

The color dialog
The color dialog lets you specify color in one of three different color models -- HSB, CMYK or RGB. HSB
is the most intuitive color model while CMYK is preferred by graphic artists. In the HSB color model, 
colors are specified using three parameters called Hue, Saturation and Brightness. Hue specifies the 
color of the color, such as blue or yellow. Saturation specifies the concentration of the selected hue with 
respect to the overall intensity. Less saturated color has some white light mixed in. If the saturation is set
to 0, you get a shade of gray. Brightness specifies the overall intensity of light. If the brightness is set to 
0, you get black.
In the color dialog, different hues are arranged around a color wheel. As you move towards the center of 
this wheel, saturation decreases. The dialog also has a brightness bar. As you move upwards on the 
brightness bar, the brightness increases.
To select a color, first select a hue by clicking at an appropriate angle on the color wheel. Now adjust the
saturation by moving towards or away from the center. Next click on the brightness bar. Move up or 
down to adjust the brightness. The currently chosen color is visible in the little square next to the 
brightness bar. Click OK to select the color.



How to pick color, pattern and other attributes from one object and apply it to another

Select the object you would like to pick color, pattern, line style and other attributes from. Now click on 
the eye dropper button on the toolbar. The current paint style will be set to the paint style of the selected 
object. Next, select the objects you would like to apply the current paint style to. Then click on the brush 
button on the toolbar.



How to draw arrow heads at ends of lines

To draw arrow heads at ends of lines, first select the lines you are interested in. Then choose any of the 
last four items in the Line menu, depending on whether you want no arrow heads, arrow head on the 
first end, arrow head on the second end, or arrow heads on both ends. Three different arrow styles are 
available--Small, Big and Fancy. To change the arrow style, select the lines you are interested in. Then 
choose the style you want from the Arrows menu. To access the Arrows menu, click on Style menu and 
then click on Arrows.



Handles are little squares that become visible when you select an object. If the handles are white that 
means that the object is grouped and cannot be edited.



How to align and space objects

To align objects, select the objects you want to align. Then choose an appropriate command from the 
Align sub-menu in the Arrange menu.

Space Evenly in the Arrange menu rearranges selected objects such that the distance between them is 
uniform. The distance between objects can be either the distance between centers of the objects or the 
space between edges of the objects.



How to group objects

Select the objects you would like to group. Then choose Group from the Arrange menu. Group objects if 
you want a set of objects to behave as one object. If you select an object that is part of a group, the 
entire group will be selected. This ensures that you do not accidentally dismantle the group by moving or
editing one of the objects in the group. Note that grouped objects have white handles instead of black. 
White handles indicate that the selected object cannot be edited. If you want to edit an object that is part
of a group, you must Ungroup the objects first.

Text objects that are part of a group can be edited without ungrouping first.



Interoperability with other applications

Export your drawing in EPS format to insert the drawing into your word processor. This version of 
PageDraw cannot import or export drawings in WMF format because of limitations of the WMF format. 
For the same reason, PageDraw cannot communicate with other applications via the clipboard.

Drawings created using PageDraw can be opened in other drawing programs such as Adobe Illustrator 
4.1, CorelDraw 6, Micrografx Windows Draw 4.0 and SmartSketch 95. First select Export from the File 
menu in PageDraw. In the Export dialog, change Save file as type to Adobe Illustrator. Enter a file name 
and click OK. Your drawing will be saved in Adobe Illustrator 88 format. This file can now be opened in 
any of the above programs.

To open a drawing created using any of the above programs in PageDraw, first start the application that 
created the drawing and export the drawing in Adobe Illustrator 88 format. Then in PageDraw choose 
Import from the File menu. PageDraw can import the AI format file you created.



How to zoom in and zoom out

Select the zoom tool from the toolbar. Click and drag a rectangle around the area you would like to zoom
in on. To zoom out, click anywhere and without moving the mouse, release the mouse button.



PageDraw is FREE software

PageDraw is Copyright (c) 1993-96 Rajeev Karunakaran

Feel free to make copies of PageDraw for your coworkers and friends. No charges are due to the author
for using PageDraw.

Permission is granted to distribute unmodified copies of PageDraw, without any charges being due to 
the author.

PageDraw is distributed with NO WARRANTY of any kind. The author or distributors of this software do 
not accept responsibility for any damages arising from the use of this software.

How to send in your comments

You are invited to send me your questions, comments, any bugs you have found, or suggestions for the 
next version of PageDraw. If you have access to the Internet, please send me e-mail at the address:

rajeev@netcom.com




